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You can download a pdf of this presentation.



file:///Users/martin/dev/gia/lectures/07/gis_in_archaeology07.pdf

Let's Get Started

1. Click this link and download 14C dates for the expansion of the Neolithic

2. Open QGIS
3. Start a new project and Add the layer
4. Add a Background Layer to know where we are...
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Interpolation

is a type of estimation, a method of constructing new data points within the range of
a discrete set of known data points. - wikipedia

Spatial interpolation is the process of using points with known values to estimate
values at other unknown points. - QGIS Manual

Example: Temperature of an area, based on the measurements of certain weather stations

Source: https.//docs.qgis.org
Temperatures in South Africa Pictedbug
on 15 April, 2009 at 11am

iExmeld
.

Welkomt e
Kimboerley 2

25

3/28


https://docs.qgis.org/

b

u

b
UNIVERSITAT
BERN

Interpolation

For many characteristics (e.g. temperature, precipitation, population density), the
area-wide collection of measured values is not feasible due to financial, personnel,
time, etc. constraints. It is therefore necessary to estimate values for unsampled
locations from samples. The so-called interpolation is a mathematical solution to the
problem of bringing values from point to area. It is based on the assumption that the
values at two points are the more similar the closer these points are together. -
https://qgis.uster.ch, translation MH

In Archaeology: We often only have this point information. If we assume that the situation at
other points in the vicinity is similar to the one for which we have point data (underlying
continuous process), interpolations can help to understand these processes.

cal years BP Source: Fort 2015
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https://gis.uster.ch/

How to bring points into area? e
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Every space around a point gets its
value
o either as raster or vector
o Gridding, Thiessen-Polygons,
Nearest Neighbor
Every space between points gets a
value that is dependent on both points
and its distance to them
o Triangulation, in GIS most often a
raster
o Delauny Triangulation rsp. TIN
(Triangulated Irregular Network)

. The value of every space (pixel) is

influenced by all surrounding actual
points
o linearly weighted combination of
values from nearby points
o |nverse Distance Weighted (IDW)
more complicated or informed
methods...
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GRID INTERPOLATE TRIANGULATE
« Uniform raster grid « Uniform raster grid - Triangulaged Irregular
- Gaps in area with no - Values estimated in Network (TIN)
data points areas with no data + No gaps
points - Larger file size

» Maintains point
distribution integrity
[] NoData

! ) ! ) m I )
200m 200m = 200m

DETERMINISTIC PROBABILISTIC
- Values estimated using distance or - Values estimated using statistical
area function spatial similarity
« Error assessment less accessible « Error estimated for predicted values.
« Less processing time + More processing time
+ Not sensitive to multi directional « Sensitive to multi-directional trends
trends in data in data

« Multi-directional

« Inverse Distance - Spline « Ordinary Kriging « Bayesian Kriging

Weighted (IDW) - Nearest Neighbor « Universal Kriging

- Natural Neighbor
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Source: https.//www.battelleecology.org
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» Most simple approach
» produces raster grids with 'gaps'

1. create a regular grid over the mapping area
2. for every cell where there is one value, this cell gets the value
3. for every cell where there are multiple values, this cell gets the mean value
4. every other cell remains empty
x x : e
X q =
x - HHHHat n! ;;
‘ 2

Point features Raster point features

Source: https://desktop.arcgis.com/

Not very convenient for areal analysis...
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Gridding in QGIS —

1. Click on 'Raster > Conversion > Rasterize (Vector to Raster)’
2. Select the Input Layer

3. Select 'CALBP' as the field that should be rastered

4. Select 'georeferenced units' as raster units

5. Select 100000 m as pixel size for width and height

6. Select the Extend of the point layer as extend for the resulting raster
7. Click on 'Run’
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Gridding in QGIS result

» you should see a raster covering the points

» pixel size defines the resolution

* if you change symbology to pseudocolor, it already looks reasonable
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Thiessen Polygons

A Voronoi diagram, also called
Thiessen polygons or Dirichlet
decomposition, is a
decomposition of space into
regions determined by a given
set of points in space, here
called centres. - german
wikipedia, translated

Technique to estimate the area affected
mainly by a point within a set of points

1. connect all neighbouring points

2. draw a orthogonal line at the middle of
the connections

3. stop, when you meet other lines
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Thiessen Polygons in QGIS

1. Click on 'Vector > Geometry tools > Voronoi polygons'

2. (You could define an additional buffer around your working area...
3. Just click on 'Run’
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Thiessen Polygons in QGIS result

The result is are polygons around your
points that contain all the values from the
attribute table of the points.

You can check by looking in the attribute
table

You can use symbology > graduated to use
the CALBP field for colorising

The result is this piece of art to the right,
blue means early, red means late
neolithisation

Of course, transparency is a nice option
here, too.
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Interpolation

You can also create a raster version quite easily.

Either you raster the Thiessen Polygons...

Polygon fealures Raster nolygen features

Or you use the Nearest Neighbor Interpolation (not to mix up with the analysis)
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Nearest Neighbor Interpolation in QGIS

1. Select 'Raster > Analysis > Grid (Nearest Neighbor)'

2. Select the input layer and specify the field CALBP as 'z value from field'
3. click on 'Run’
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Nearest Neighbor Interpolation in QGIS Result

The resulting raster is equivalent to the Thiessen Polygon Solution... only as raster
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TIN (Triangulated Irregular Network)

» Another interpolation technique placing more focus on dynamics between the actual points
» the surface is divided in triangles, where the data points are the corners
» these triangles are placed in 3d (x,y and the interpolated value as z) and rastered

(2) Triangulated Network (b) Triangulated Geometry

Figure 2.15 Triangulated Irregular Network (TIN)

Source: https://courseware.e-education.psu.edu; http.//sar.kangwon.ac.kr/
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TIN Benefits / Disadvantages

e more dynamic interpolation than simple gridding or Nearest Neighbor
« interactions/differences between data points are better interpolated
e very good for interpolating rather regular elevation measurements

but

 highly irregulare point patterns can result in 'strange' networks

Figure 4: TIN face same symbol

Source: http://www.geocomputation.org; Bhargava et al. 2013
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TIN in QGIS
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In the toolbox L , search for 'tin'
Select "'TIN Interpolation’

Select the input layer

Select CALBP as interpolation attribute
Click on the '+'icon

Select the extend to be calculated from
the layer extend

Specify the resolution either in width or
in height

(if you want to see the network itself,
select eg. Temporary Layer from the
Triangulation)

Click on 'Run'

b

u

b
UNIVERSITAT
BERN

B ielp | AlsBatenprozess starten *close [Fstane



TIN result

» As a result, you should see grayish triangles
» After selecting pseudocolor, the expansion of the neolithic is again nicely visible
* if you selected the output of the Triangulation, you can overlay this (right picture)
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Projekt Bearbeiten Ansicht Layer Enstellungen Erweiterungen Vektor Raster Web Netz Verarbeitung Hille

Projekt Bearbeiten Ansicht Layer Enstellungen Erweiterungen Vektor Raster Web Netz Verarbeitung  Hile

)= 8 Ol » PRRLiEBasbLlOR @ - x - PRALEaGLEOR x -
% @ e e
T
Verareitngswerkzeue @8 Browser P e
L S " gevmeo R e \
en in a en wn a
» (% Riumiihe Lesezeichen T Kl venvendet T s 1 Raumiche Lesezeichen O Kzl verwendet A
+ o Prjektverzechnis © @ oren + o Projektverzechnis © Q Datenman
v . # In SpatiaLite exportieren » (@ Home In Spatialite exportieren
N Nach PostgreSQL exportieren *Bo Nach PostgreSQL exportieren
- Q interpataton © Geopaciage - Q inerpataton
TIN-Inte # Spatialite T —
~ @ Netz Post ~ @ Netz
# TIN-Netzerzeugung » wssat # TIN-Netzerzeugung
~ Q@ Vektoranalyse @ oax ~ @ Vektoranalyse
3 GrndstatiskarFeder @ whisivrs 3 GrndstatistarFeder
#4 Unlentingen sumieren 8 VecorTies #4 Unlentingen summieren
3 Punkte in Polygon zahlen Tie 3 Punkte in Polygon zahlen
© tatstk nach Kategoren % Statstk nach Kategoren
- @ Vektorouswatt 5 06C AP - Featres - @ Vektorauswan
o a Nach Position extrahieren ows = - Nach Position extrahieren
- lach Position selektieren @ ArcGIS-Map-Dienst - h Position selektieren
& Arcis Festure Diest G = | @ s pesture Dienst ¢ - @ Vektorenatgemein |
3 GeoNode - 3 GeoNode a
} Ergebnisanzeige an I Ergebnisanzeige a8
fres os X " ’ "
«@wT FAOL I
Triangulation 2
W 40201926
S2ca7268 e
asm2610
Tres 952
M 5014,3294 f V& 4 A
'+ neoitic_expansion ¢ . 4 ¢ 5 s
v 73
v/ [l 7331 - 9080 v/ [l 7331 - 9080
- )3 positron - )3 positron
uchender Typ (Strg K] Seateitngsatndes kel Loyrs achaben Koordnoce TBGTS871404% |9 Mobstab 126886010 |- | @ Vergrstorung 100% 2 Drerung |00° Vizamen Swscn @ F uchender Typ (Strg K] e Koordinate| 2501851038203 | 5 Madsab 120888000 |~ | @ Vergsbarung|100% |2 Drehung (00" |2| Vi Zokhnen @erscaoss @ @9

18 /28



Inverse Distance Weighted (IDW) e

» archaeological data most of the time represent a biased random selection

 the individual date is 'untrustworthy'

e probably you are more interested in the underlying pattern than the value of the individual
date

» Inverse Distance Weighted (IDW) consider all points around a certain cell (pixel) to be
interpolated

» the further away a point is, the less impact it should have

Tobler's first law of geography: everything is related to everything else, but near
things are more related than distant things

Sample Points

T E
*
\ 3
=+ / Sample Points
N “ f:
,,,,,, -+
7 2 ,:':'-:-;-"""-I-
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Source: https://docs.qgis.org
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Inverse Distance Weighted (IDW) e

for a pixel to interpolated:

» take all the points and their values
 'calculate a mean' in so far, as values
close to the pixel have a higher impact
than values further away
* how much distance is 'penalizing'
depends on the 'power’ value:
o higher power result in points further
away have lesser impact o

Value

RPNWACION® O

QCOOOOOO0O0OO
B

Distance )

Source: http://www.geography.hunter.cuny.edu. Left image: green line: smaller power value, dashed line: higher power value
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IDW in QGIS
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In the toolbox é‘”?f% , search for 'idw'
Select 'IDW Interpolation’

Select the input layer

Select CALBP as interpolation attribute
Click on the '+' icon

Select the extend to be calculated from
the layer extend

Specify the resolution either in width or
in height

Specify the power P. You can leave it for
now at the default value 2.

Click on 'Run'
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IDW in QGIS result

 after changing to pseudocolor, the result
is much more regionalised

» the higher the power, the more the
individual points will be relevant (more
'measles’)

e the lesser the power, the more the
general pattern will be visible
(smoother)
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Contours

e Colors give already a good impression
about the general pattern

e Contours are lines connecting positions
of the same value in a raster dataset
representing continuous phenomena

e Contour lines are useful in surface
mapping, as they make it possible to
visualise both flat and steep surfaces
(distance between contour lines) and
ridges and valleys (approaching and
diverging lines)

» they also can be used to enhance the
visualisation of interpolation
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https://www.giscourse.com/

Contours in QGIS

W

24128

Select 'Raster > Extraction > Contour'
from the menue

Select the input layer

(In multichannel raster you might need
to select the correct channel)

Specify the distance between the
contour lines

(If your range should not start from O,
you could define an offset)

Click on 'Run'
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Contours in QGIS Result m

Now you should see the interpolation enhanced with contour lines, that make it easier to spot
patterns...
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What We've Covered
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What is interpolation, and what is it
good for

Gridding

Thiessen Polygons and Nearest
Neighbor

TIN (Triangulated Irregular Network)
Inverse Distance Weighted (IDW)
Contour lines

Predict values

outside of
sample point
TIN
IDW
Spline
Natural Neighbor
Ordinary Kriging
Universal Kriging
Bayesian Kriging

<K K

Inherent Error
Predicition

<<
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What to choose for what?

Good for

Gridding: rarely the best option
Thiessen Polygons: if you assume
homogenous, delimited areas

TIN: if the actual values are more
relevant

IDW: if the underlying process is more
relevant

Surface passes

variable point Good for dense through sample

spacing

v

KKK

point spacing points
v v
v
v
v
v
v
Vv

Source: https.//www.battelleecology.org


https://www.battelleecology.org/

Homework

Get the archaeological sites of the Kanton bern with elevation (field: altitude1)

try out different interpolation algorithms

Which algorithm gives the best result for interpolation of elevation?

Send me your assessement and the best result via email (martin.hinz@iaw.unibe.ch) as
screenshot or exported map

27128


https://github.com/BernCoDALab/gia/raw/main/lectures/07/data/fundstellen_mit_hoehen.zip

b

u

b
UNIVERSITAT
BERN

uestions?

Destruction
Island

You might find the course material (including the presentations) at

You can see the rendered presentations at

You can contact me at



https://www.instagram.com/sadtopographies
https://github.com/BernCoDALab/gia
https://berncodalab.github.io/gia
mailto:martin.hinz@unibe.ch

