
GIS in Archaeology
11 - Time Distance and Site Catchment Analysis

Martin Hinz

Institut für Archäologische Wissenschaften, Universität Bern

11/12/24

You can download a pdf of this presentation.

file:///Users/martin/dev/gia/lectures/11/gis_in_archaeology_11.pdf


Before we start:
You might need to download the following data, if you do not have them on your PC right now:

SRTM DEM of Switzerland in EPSG 2056
The start point as shapefile vector layer
The end point as shapefile vector layer
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https://github.com/BernCoDALab/gia/raw/main/lectures/11data/srtm_2056_cut.tif
https://github.com/BernCoDALab/gia/raw/main/lectures/11data/start.zip
https://github.com/BernCoDALab/gia/raw/main/lectures/11data/end.zip


A small repetition
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1. find the most cost-effective step from
the starting point

2. note the cost and mark the destination
of the step.

3. find the cheapest step from a visited cell
adjacent to an unused cell

4. note the costs and the starting point of
the step and the destination

5. repeat 3 and 4 until the target point is
reached.

6. reconstruct the best route by stringing
together the best connections from the
destination to the starting point.(after
Oliver Nakoinz)

Dijkstra-Algorithm
The basic idea of the algorithm is to always follow the edge that promises the
shortest route section from the start node. Other edges are only followed if all
shorter route sections (also beyond other nodes) have been considered. This
procedure ensures that when a node is reached, no shorter path to it can exist. -
wikipedia
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Some Movement Directions
More possible directions -> more precise results, but also more computational time
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Costs are calculated per cell
if you move along a slope, you actually
walk on an even elevation
if the movement direction is not
considered, it is isotropic
if they are taken into account, it is
anisotropic

more accurate, but more calculation
intensive
travel direction matters: The path
from a -> b can be different than
the path from b->a

The cost raster is isotropic, the plugin uses
Dijkstra and Manhattan (Neumann)
Neighborhood. There is a way independent
from the plugin using SAGA, but we will not
cover this here...

Source: David Lewis; Ray/Ebener 2009

Isotropic vs. anisotropic Analysis
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Comparison between 5 hour isochrones, with and without slope.
Source: http://www.chrismapsthepast.com

calculates the walking time in any
direction
if a maximum time is given, it is possible
to determine the area reachable within
this time
can be used to estimate a territory used
by a settlement
can be based on terrain and other cost
changing aspects (roads, barriers)

Comparison between a Thiessen-Polygon and an Cost-Defined
(XTENT) model of the territories of the Maya lowland. Source:
Ducke/Kroefges 2007

Calculating walking time from a given start point

If you want to know, which points can be reached in what or a given
time
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http://www.chrismapsthepast.com/


We need to utilize another GIS inside QGIS:
GRASS.

There is a function r.walk that calculates
walking time.
You can parameterise it for different
Walking Cost functions, we work with
the default (although it might be not
optimal)
It expects a start point, an elevation
model and a 'friction cost' layer

With the friction cost you can
introduce other costs beside the
slope
This is not the cost layer we just
calculated
To make our walking time only
dependend on the slope, have to
define a neutral raster layer
containing only zeros (0)
We can use the raster calculator for
this

Calculating in QGIS - Prerequisists
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Start the raster calculator
Select the DEM layer as template
Write '0' in the 'Expression' pane
Specify the output file, name it eg.
'cost0'
Click on OK

Creating a empty (zero) layer
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Open the Toolbox 
Search for 'r.walk' and open the
'r.walk.points' tool
Select DEM, cost0 and start layer
[you could define a stop point, where
the maximum costs will be reached]
[you also can define the formula for the
walking function. It defaults to Langmuir]
[in the advanced settings, you can
specify using 'Kings move', it defaults to
Manhattan move]
Click on Run

Calculating in QGIS - Actual Calculation
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left: movement directions; right: cumulative movement costs, colored with pseudocolor spectra, inverse

r.walk results
You get two resulting layers:

Movement directions contains the movement choosen for the calculation at each raster cell
More relevant is 'Accumulated Cost'

Here, the raster holds the walking time to the pixel cell from the start point measured
in seconds
You can color this using pseudocolor, spectral, inverse
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Creating a Least Cost Path from the Accumulated
Cost Surface
We can use the Accumulated Cost Surface to calculate a Least Cost Path solution using the
SAGA Least Cost Path tool

We have the costs from Bern
We need to calculate the path from Basel
Intuition: The algorithm treats the start as source of a river and lets this flow to the deepest
point on the surface: the origin of the cost surface, that is Bern.
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Creating a Least Cost Path from the Accumulated
Cost Surface - practically

Search in the toolbox for 'Least Cost Path' from SAGA
Click to open
Select the 'end'-layer as source
Select the Accumulated cost layer as Raster layer
Click on Run
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left: The result from the LCP Analysis from Bern -> Basel; right: Comparision between different algorithms and settings. Green: The result from the
plugin. Blue: The result from SAGA Bern -> Basel. Red: The result from SAGA Basel -> Bern.

SAGA Least Cost Path results
You get two resulting layers:

A Vector Line Layer and Point layer both indicating the least cost path
The result might differ from the plugin path (different cost function).
r.walk is anisotropic, so the path from Bern to Basel might be a different one than the path
from Basel to Bern
Which one is the best for archaeological interpretation? You need to decide!
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Source: Rudnick et al. 2012.

Least Cost Corridors
A Least Cost Corridor does not identify a single most cost-efficient route between two starting
points, but indicates the area of the least common costs between two points.

That is, the lowest accumulative cost to reach starting point 1 plus the lowest accumulative
cost to reach starting point 2 gives the total accumulative cost for a route that passes through a
cell.

Least cost corridors can be used instead of a single least cost path to connect two sites and get
the optimal corridor for interaction instead of a single path.
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Calculating Least Cost Corridors, Preparations

We need:

Two Accumulated Cost surfaces, one starting from each point
A threshhold to define inside and outside the corridor (we will determine that empirically)
A way to sum both surfaces up (this will be surprisingly straight forward)

So please:

Calculate a second Accumulated Cost Surface starting from Basel using r.walk
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Calculating Least Cost Corridors, Actual
calculation

Open the Raster Calculator
Double click the first Accumulated Cost Surface
type '+'
Double click the second Accumulated Cost Surface
Select output file and check correct CRS
Click on OK
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Continuous and discrete visualisation of the Least Cost Corridor, here overlayed by the calculated Least Cost Paths.

Calculating Least Cost Corridors, Visualisation
You should get a raster that combines the costs from both directions
You and visualise it very well with inverse spectral
You can also define a discrete threshold value (here eg. 71000)

You might than like to multiply the layer on top of your DEM
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search for 'contour' in the Toolbox 
Click on 'Contour lines' tool from SAGA
Set 'Cumulative Costs' as layer
Set x,y as 'Support point type'
Set maximum and minimum to 3600
click on 'Run'

Calculate the movement distance within a given
time
To get how far a pedestrian can walk in a given time, we can use the Contour tool, this time
from SAGA:

here we can set maximum and minimum value for the contour line
the walking time is in seconds, so eg. 1 hours is equivalent with 1 x 60 x 60 = 3600
seconds
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left: movement directions; right: cumulative movement costs, colored with pseudocolor spectra, inverse

Walking distance results
You should get a line showing the extent of a walking time of 1h
You can make it stick out more using Symbology (here: neon glow)
If you make the actual cost layer invisible, you can compare with the base map
In 1 hours I could get eg. to Kehrsatz
Compare with Google Maps: 1h 10 min including river crossing
or try it out yourself ;-)
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Used to estimate how many resources
were available per (settlement) site
within the catchment area
Practical approach:

Defining the catchment area
Defining indicators for resources
Calculation of the available
proportion/quantity

Typical surveyed factors:
Soil types
soil quality
Slope inclination
humidity
(Climatic factors)

Site Catchment Analysis (SCA)
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Probably managed/used space at a
given distance from the site

Ressources used differ in relation
to distance
Relative distance (in costs) might
differ in relation to the topography

Basic idea: von Tünen
Size of the catchments derived from
ethnographic data

typical:
close vicinity 1 km or 20 min walk:
Horticulture or other high intensity
activities
medium vicinity 5 km or 1 h walk:
agricultural fields
far vicinity 25 km or 1 day walk:
extensive activities, eg. herding

SCA - Background
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first systematic application in
archaeology: Vita-Finzi/Higgs 1970
landscape "reconstructions" give the
opportunity to evaluate the economic
potential of catchment
zonal approach
Catchments of different sites can be
compared (-> site functions)
Does the catchment have enough
potential to supply the site?

Vita-Finzi/Higgs 1970

SCA - History and Application
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Catchment of 1h walk around Bern

SCA - What do we need
an estimation of the catchment (we just did that)
data on ressources, which can come as

Raster: DEM, Slope, Aspect, Distance to Water, ...
Vector: Soil Types, Water Bodies, location of specific ressources, ...

What we might get out: Percentages of area with specific environmental values
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SCA - Preparation

Catchment as Polygon

To use the walking distance border for extracting informations, we have to transform it into a
polygon.
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SCA - Vector Data
Informations like soil types might come as vector (polygon) data. What we like to know is how
many area is covered by the specific soil types (or other areas classified by attributes).

Please download the soil data for switzerland and add them to your map. The dataset is a
simplified and reprojected version of what you can download from geo.admin.ch...

The layer contains fields (columns) with multiple soil productivity parameters. We will use the
'Eignungsei', containing informations of suitability for different land uses.

We need to:

cut to the extend of our catchment area
combine polygons according to soil suitability classes
calculate the size of the individual polygons
turn this into percentage of the total catchment area

The last two steps can be done in one go in the attribute table
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https://github.com/BernCoDALab/gia/raw/main/lectures/11/data/boden_2056.zip


SCA - Vector Data

Cut to extent

Remember Geoprocessing tools?

Go to 'Vector > Geoprocessing tools > Intersection'
Select the soil layer as Input
Select the polygon as overlay
click on Run
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SCA - Vector Data

Cut to extent Result

You now have extracted the polygons according to the catchment area.

We can remove the original layer 'boden_2056'.
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SCA - Vector Data

Combine polygons according to classes

Now we have to combine all polygons for the different suitability classes into one object. The
attribute table will than have a row for every suitability class (Eignungsei)

Go to 'Vector > Geoprocessing tools > Dissolve'
Select the Intersection Layer
Select 'Fields to dissolve' and select 'Eignungsei'
Click on 'OK' and then on 'Run'
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SCA - Vector Data

Combination Result

The result is a new layer. Please open the attribute table (Right click on the layer > Attribute
table) to inspect the result.

From this result we can calculate the percentage on the total area
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Stay in the attribute table, Click on the pencil
icon  to toggle edit mode.

At first, we have to make a new column.
Click on the 'Add column' icon , and add
a field for our percentage calculation, type
should be 'real number'.

SCA - Vector Data

Calculate percentage of area

In the next and last step, Select the new field in the drop down to the upper left, and type the
following formular:

'$area/sum($area)*100'

Then click on 'Update all'.
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SCA - Vector Data

Result

The result shows the percentages of use classes on the area of our Catchment

By far, 'Settlement' is dominating... Downside of working with modern days data. Get better
suited or reconstructed if possible!
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SCA - Raster Data
To assess the suitability, we can also use raster data. We might use the slope data from our
DEM. Do you still know how to calculate this?

'Raster > Analysis > Slope'

We can cut the resulting Raster, like we did it for the vector data, but with a different tool.

'Raster > Extraction > Crop Raster to Layer Mask'
Select the raster as input and the polygon layer as mask
Click on 'Run'
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SCA - Raster Data

Result

The difficulty with raster (continuous) data is, that they can take an infinite number of values. So
either we represent them graphically, like inbuild, as histogram, or we have to reclassify them to
a finite, small number of classes.

(Histogram: Right click on the layer > Properties > Histogram)
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SCA - Raster Data

Reclassify

We might want to reclassify according to the following table

Slope in degree Suitability numeric value

0-5 Good 1

5-10 Fair 2

10-15 Bad 3

> 15 Unsuitable 4

We can use the 'Reclass by table' tool from the Toolbox  for this
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SCA - Raster Data

Reclassify practically

Select the tool from the toolbox (you might need to search for it)
Select the correct layer
Click on the ... at Classification Table
Add our classes
Remember to set numeric values
Click on 'OK' and 'Run'
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SCA - Raster Data

Reclassification Results

The result (in pseudocolor) can be seen below. Now we still have to calculate the percentage
on the total area.

For this, we can use again a tool from the Toolbox : 'Raster layer unique values report'
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Reclassification calculate areas

Select Input Layer
Add Export of Table of Unique Values to
Temp. File
Click on 'Run'
Open the Attribute Table of the new
Table
Toggle Edit Mode 
Add a decimal Field
Calculate the value of the field with:
m2 / sum(m2) * 100

SCA - Raster Data
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SCA - Result
Now we have the tools to analyse the catchment of a site:

Determining the catchment by walking time
extract informations from underlying Raster and Vector Layers
Display the results numerically and as maps
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What We've Covered
Creating a cumulative cost (walking time) layer
Calculation of Least Cost Corridors
Estimation of walking distance in a given time
Creating a Catchment area from walking time
Extracting Catchment data from Raster and Polygon Data
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Volkmann A. (2018) Methods and
Perspectives of Geoarchaelogical Site
Catchment Analysis: Identification of
Palaeoclimate Indicators in the Oder Region
from the Iron to Middle Ages. In: Siart C.,
Forbriger M., Bubenzer O. (eds) Digital
Geoarchaeology. Natural Science in
Archaeology. Springer, Cham.
https://doi.org/10.1007/978-3-319-25316-9_3

Free available from within the university
network.

other chapters of the book might be
interesting, too...

More on Site Catchment Analysis
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https://doi.org/10.1007/978-3-319-25316-9_3


Homework
Select a locations of your choice (in Switzerland or the world)
Get the DEM from SRTM
Calculate the 1h Catchment
Evaluate a parameter of your choice in terms of the percentage of the catchment (slope is
probably the easiest...)
Send me a screenshot
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Source: https://www.instagram.com/sadtopographies

Any questions?

You might find the course material (including the presentations) at

https://github.com/BernCoDALab/gia

You can see the rendered presentations at

https://berncodalab.github.io/gia

You can contact me at

martin.hinz@unibe.ch
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https://berncodalab.github.io/gia
mailto:martin.hinz@unibe.ch

